Linux on Dell E521 (en)

Aus FelixSchwarz

Wechseln zu: Navigation, Suche

This page summarizes my experiences with running Linux on a Dell E521. I'm using Fedora Core 6 (x64 mode) but many problems with the hardware should be the same for every version of Linux...

Dell advertises (at least in the US) this computer for its Linux capabilities: Are you looking for a desktop on which you can run Linux® or other open-source operating systems? Look no further!. [1]

Furthermore, the German computer magazin c't tested it[2] and didn't mention any Linux problems (their Linux compatibility test with Suse 10.1x64 showed no failures). So I went for the E521. Unfortunately, it had several problems with Linux when it was introducend, especially when using XEN (November 2006) -- and I hoped that I can get rid of VMware Server with XEN...

As of April 2007 there are no real big issues with the hardware when I use Fedora Core 6 with the latest updates. However a fresh FC6 install may cause problems.

Update July 2007: Fedora 7 works well on the machine (updated to bios version 1.1.10). The only remaining problems are numpad/repeating keys.

Update November 2007: Fedora 8 works even better (using bios version 1.1.11). Everything worked out of the box. No repeating keys any more, only the numpad problem is still there (but appear only very occasionally).


Inhaltsverzeichnis

Hardware

Athlon64 X2 4200+ with 4 GB RAM


Problems

First of all, you should install bios version 1.1.4 (released on 01/01/2007). This solved my boot and usb problems. See Flashing a Dell Bios with Linux (en).

Boot (solved)

Installing/booting hangs... No differences between kernel builds 2798 and 2849.

On 01/01/2007 Dell released a new bios version (1.1.4) which fixes this problem for me.

Dell recommended workarounds: Add "acpi=noirq" to kernel command line. Alternatively you may try adding "enable_8254_timer" instead.

The kernel output before the hang looked like this:

MP-BIOS bug: 8254 timer not connected to IO-APIC
...
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cgq registered (default)
(hang)

Ethernet (solved)

While installing Fedora, everything worked (did an HTTP install). After the installation, Broadcom ethernet does not work.

ifup eth0
Error for wireless request "Set Encode (8B2A) :
    SET failed on device eth0 ; No such device.

lines from /var/log/messages (with XEN)

Nov 27 18:44:58 localhost kernel: b44.c:v1.01 (Jun 16, 2006)
Nov 27 18:44:58 localhost kernel: ACPI: PCI Interrupt Link [APC4] enabled at IRQ 19
Nov 27 18:44:58 localhost kernel: GSI 20 sharing vector 0xC8 and IRQ 20
Nov 27 18:44:58 localhost kernel: ACPI: PCI Interrupt 0000:04:07.0[A] -> Link [APC4] -> GSI 19 (level, low) -> IRQ 20
Nov 27 18:44:58 localhost kernel: b44 0000:04:07.0: No usable DMA configuration, aborting.
Nov 27 18:44:58 localhost kernel: ACPI: PCI interrupt for device 0000:04:07.0 disabled
Nov 27 18:44:58 localhost kernel: b44: probe of 0000:04:07.0 failed with error -5
Nov 27 18:44:58 localhost kernel: input: PC Speaker as /class/input/input2

lines from /var/log/messages (without XEN, no problems)

Nov 27 18:12:40 localhost kernel: b44.c:v1.01 (Jun 16, 2006)
Nov 27 18:12:40 localhost kernel: b44: eth0: Link is up at 100 Mbps, full duplex.
Nov 27 18:12:40 localhost kernel: b44: eth0: Flow control is off for TX and off for RX.

Kernel module not built: It is not bug 187929. The kernel module exists. Therefore [1] doesn't apply either.

XEN: Booted without XEN. Network is okay!

Update 11/28 15:09: The b44 chipset is not able to handle 31 bit DMA addresses so can only use memory below 1GB. XEN currently has no mechanism to restrict the dma memory given to the b44 to that region. Source: Xen users mailinglist.

Update 11/28, 15:20: There is bug 208242 at Redhat. The updated kernel package solves the problem on my computer! Great!

Update 01/21/2007, 15:46: Unfortunately, the Redhat patch is not included in an official Fedora Kernel RPM although everything (nearly) everything works for me. After I installed an additional 3com network card, my guest won't be started anymore.

Update 04/19/2007, 20:49: Fedora kernel 2.6.20-1.2944.fc6xen contains the b44 patch - Xen networking with the latest kernels! Yai!

no sound (solved)

Chipset is MCP51 ("STAC92xx Analog" is shown). There is a success report from 04/2006 and alsa-driver-1.0.11rc3, Fedora ships 1.0.12rc1 so that should work...

Update 11/27, 18:14: Without XEN, sound works!

Update 11/28, 14:39: Sounds works now with and without XEN. Don't know why.

Update 11/29 13:26: Remaining sound problems: "alsamixer" does not work, volume is muted at startup, alsa related error messages during shutdown.

Update 01/19 21:56: Problems solved with new kernel.


alsamixer

$ alsamixer
alsamixer: function snd_mixer_load failed: Invalid argument

gnome-volume-control says the device is called "SigmaTel STAC9227 (OSS Mixer)".

Error at shutdown:

alsactl: get_control:149: Cannot read control info '2,0,0,Capture Volume,0': Invalid argument


microphone (works)

One visitor of this website had problems with the microphone recording which I did not use. After getting a working microphone, I tested the recording using the command line utility 'rec' and everything worked fine (front+back).

USB (solved)

USB mouse gets disconnected very frequently. Sometimes it works for 5-10 minutes, sometimes only not for a single one. Replugging helps most of the times, but not always. Keyboard disconnects do not happen so often, but still. This must be fixed. Using a USB hub (passively powered) worked for me as a workaround.

On 01/01/2007 Dell released bios version 1.1.4 which solved the problem for me.

bug reports:

forum threads:

This is not a "Linux-only" kind of a problem. FreeBSD has it too: [2]

Boot messages

There are some boot messages about bugs/errors during startup. However, I do not see a direct relation to my problems described above.

PCI: BIOS Bug: MCFG area at f0000000 is not E820-reserved
...
PCI: Setting latency timer of device 0000:00:04.0 to 64
pcie_portdrv_probe->Dev[02fb:10de] has invalid IRQ. Check vendor BIOS
assign_interrupt_mode Found MSI capability
...
ata3: SATA link down (SStatus 0 SControl 300)
ATA: abnormal status 0x7F on port 0x9E7
ssci3: sata_nv
ata3: SATA link down (SStatus 0 SControl 300)
ATA: abnormal status 0x7F on port 0x967

Missing RAM (resolved)

Sometimes, not all of my RAM (4 GB) is usable in Linux. Up to 1,5 GB are missing. This may a problem related to Xen: When the system is booted, 4 GB show up but after working a bit, starting some Xen guests etc, some memory is missing.

Update 03/19/2007: This is expected behavior when using Xen, see Andrew Cathrows explanation how to reclaim the RAM for Dom0.

Numpad

The number pad does not work 100% reliable: Sometimes you have to press the '2' key a bit harder than other keys else the key press is missed. Furthermore the NumLock light is sometimes on although Linux does not convert key presses on the number pad as number. In this case, I have to press NumLock three times until the NumLock is activated again.

Update 08/11/07: This bug is still present in Fedora 7.

Repeating keys (solved)

Sometimes when I use the cursor keys, the currently selected input field is filled by digits as if I press one key repeatedly. The specific digit depends on which cursor key I used last (mostly '2', '4' and '8' appear). I can stop this by just pressing ESC.

Update 11/21/2007: I don't see this problem anymore with Fedora 8.

Notes

  1. Dell n-Series Desktop page
  2. c't 24/2006, pages 102-104
Persönliche Werkzeuge